Atlassian Confluence CVE-2023-22515: Critical Zero-Day Fix
Atlassian Confluence CVE-2023-22515 lets external attackers create unauthorized administrator accounts in Data Center and Server instances. Affected versions start at 8.0.0; upgrade to fixed versions 8.3.3, 8.4.3 or 8.5.2 and check for indicators of compromise. Atlassian Cloud sites are not affected.
Summary written with AI from this article, and checked against it.

At a glanceCVE-2023-22515
CVE-2023-22515 has a CVSS 3.1 base score of 9.8 (Critical) from NVD, and 10.0 (Critical, CVSS 3.0) from Atlassian. It is fixed in Atlassian Confluence Data Center 8.3.3, 8.4.3 and 8.5.2.
| Severity | 9.8 Critical (CVSS 3.1, NVD) · 10.0 Critical (CVSS 3.0, Atlassian) |
|---|---|
| Fixed in | Atlassian Confluence Data Center 8.3.3, 8.4.3, 8.5.2 |
| Affected | Atlassian Confluence Data Center 8.0.0 – before 8.3.3; 8.4.0 – before 8.4.3; 8.5.0 – before 8.5.2 |
| Exploited | Yes: in CISA's Known Exploited Vulnerabilities catalog since October 5, 2023 |
| EPSS | 99.2% chance of exploitation in the next 30 days (FIRST, October 27, 2026) |
| Public exploit | packetstormsecurity.com, packetstormsecurity.com · 31 GitHub repositories name it: proofs of concept, scanners, detections. Unverified: some are fake or malicious. |
| Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
| Weakness | CWE-20 Improper Input Validation |
| Ubuntu | Not tracked yet |
| Debian | Listed, no packages yet |
| Red Hat | Not tracked yet |
| Also in | Atlassian confluence server |
Is there a public exploit for CVE-2023-22515?
Yes: CVE-2023-22515 is exploited in the wild. CISA added it to its Known Exploited Vulnerabilities catalog on October 5, 2023. NVD links 2 exploit references and 31 public GitHub repositories name it: proofs of concept, scanners and detections. None of it is verified: some such repositories are fake or carry malware, so read the code before running it, and only against systems you own. FIRST's EPSS puts the chance of exploitation in the next 30 days at 99.2%, higher than 99.9% of scored CVEs.
Atlassian recently released patches to address a significant zero-day vulnerability affecting Confluence Data Center and Server instances. This article delves into the details of this critical flaw identified as CVE-2023-22515, its risk score, and the recommended steps for mitigating the issue. Importantly, it clarifies the versions that are vulnerable and offers guidelines for administrators and security teams.
Summary of the Issue
Atlassian has released urgent patches for a critical vulnerability that affects Confluence Data Center and Server instances accessible over the internet. This flaw, designated as CVE-2023-22515, permits external attackers to exploit the system and create unauthorized administrator accounts on Confluence servers. In terms of its Common Vulnerability Scoring System Version 3 (CVSSv3) score, it is rated at 9.8, emphasizing its severity.
Risk Scoring and Assessment
The vulnerability has been given a CVSSv3 score of 9.8. This score reflects multiple factors such as the ease of exploitation, the level of privileges gained, and the impact on system integrity. It's critical to understand that this score indicates an urgent need for immediate action, considering that vulnerabilities with such high scores are considered severe threats to system security.
Vulnerability Details and Scope
The flaw allows external attackers to generate unauthorized Confluence administrator accounts and thus gain control over Confluence Data Center and Server instances. These instances should especially be accessible publicly for the vulnerability to be exploited. It should be noted that Atlassian Cloud sites are not affected by this vulnerability, a fact that provides some relief for enterprises using cloud-hosted solutions.
This particular vulnerability affects Confluence Data Center and Server versions starting from 8.0.0. It is categorized as a remote exploit requiring low complexity and no user interaction, making it even more dangerous. Atlassian has recommended upgrading to fixed versions 8.3.3 or later, 8.4.3 or later, and 8.5.2 (Long Term Support release) or any subsequent version for maximum security.
Recommendations for Mitigation
Assess Your Installation
Begin by identifying the specific version of your Confluence Data Center or Server. Ensure you know whether your systems are running the vulnerable versions, specifically 8.0.0 and onwards. Conduct a thorough audit to isolate any affected instances.
Prioritize Upgrade
If your assessment confirms that your installations are among the affected versions, it becomes imperative to prioritize upgrading to a version that Atlassian has verified as secure. Atlassian strongly advises upgrading to versions 8.3.3, 8.4.3, or the Long Term Support release 8.5.2.
Implement Mitigations
When an immediate upgrade is unfeasible, alternative measures need to be implemented. These can include blocking access to specific endpoints, particularly the /setup/*, to mitigate known attack vectors associated with this vulnerability. While not a long-term solution, these mitigations can offer some level of security.
Engage Security Team
Given the severity of this vulnerability, a collaborative approach is essential. Engage your security team to conduct a comprehensive security assessment, focusing on identifying any indicators of compromise. This will help to ensure that your Confluence instances are secure and uncompromised.
Final Thoughts
Addressing the CVE-2023-22515 vulnerability in Confluence Data Center and Server instances is not just recommended; it is essential for maintaining secure and reliable systems. It is vital for organizations to act swiftly, apply patches where possible, and consider all available mitigation options. A collaborative effort involving system administrators and security teams can effectively manage this severe threat, safeguarding organizational data and maintaining system integrity.
Source
- CVE recordCVE-2023-22515 in the National Vulnerability Database · nvd.nist.gov



